summaryrefslogtreecommitdiff
path: root/guix.scm
diff options
context:
space:
mode:
authorMasaya Tojo <masaya@tojo.tokyo>2020-10-22 14:53:39 +0000
committerMasaya Tojo <masaya@tojo.tokyo>2020-10-23 23:57:59 +0900
commit30aa68089dc2f353a6c17e1ea83c61dd2b06aede (patch)
tree2386445aa7ed5be745f6598056e50345722fcab8 /guix.scm
Initial commit.
* COPYING: New file. * Makefile.am: New file. * README.org: New file. * README.md: Delete file. * bootstrap: New file. * build-aux/test-driver.scm: New file. * configure.ac: New file. * guix.scm: New file. * pre-inst-env.in: New file. * rabbit-prover.scm: New file. * toot.scm: New file.
Diffstat (limited to 'guix.scm')
-rw-r--r--guix.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/guix.scm b/guix.scm
new file mode 100644
index 0000000..92731d5
--- /dev/null
+++ b/guix.scm
@@ -0,0 +1,47 @@
+;;; Rabbit Prover --- Prove S-expression
+;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
+;;;
+;;; This file is part of Rabbit Prover.
+;;;
+;;; Rabbit Prover is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or
+;;; (at your option) any later version.
+;;;
+;;; Rabbit Prover is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+;;; General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Rabbit Prover. If not, see <http://www.gnu.org/licenses/>.
+
+(use-modules (guix packages)
+ ((guix licenses) #:prefix license:)
+ (guix git-download)
+ (guix build-system gnu)
+ (gnu packages)
+ (gnu packages autotools)
+ (gnu packages guile)
+ (gnu packages pkg-config)
+ (gnu packages texinfo))
+
+(define guile-rabbit-prover
+ (package
+ (name "guile-rabbit-prover")
+ (version "0.0.0")
+ (source (string-append (getcwd) "/rabbit-prover-" version ".tar.gz"))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (synopsis "Prove S-expression")
+ (description "Rabbit Prover is Prove S-expression.")
+ (home-page "https://gitlab.com/tojoqk/rabbit-prover")
+ (license license:gpl3+)))
+
+guile-rabbit-prover