summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 921ba1e..e17dad2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,20 +1,20 @@
-## Rabbit Prover --- Prove S-expression
+## Vikalpa --- Proof Assistant
## Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
##
-## This file is part of Rabbit Prover.
+## This file is part of Vikalpa.
##
-## Rabbit Prover is free software; you can redistribute it and/or modify it
+## Vikalpa is free software; you can redistribute it and/or modify it
## under the terms of the GNU General Public License as published by
## the Free Software Foundation; either version 3 of the License, or
## (at your option) any later version.
##
-## Rabbit Prover is distributed in the hope that it will be useful, but
+## Vikalpa is distributed in the hope that it will be useful, but
## WITHOUT ANY WARRANTY; without even the implied warranty of
## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
## General Public License for more details.
##
## You should have received a copy of the GNU General Public License
-## along with Rabbit Prover. If not, see <http://www.gnu.org/licenses/>.
+## along with Vikalpa. If not, see <http://www.gnu.org/licenses/>.
GOBJECTS = $(SOURCES:%.scm=%.go)
@@ -41,10 +41,14 @@ godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
bin_SCRIPTS =
-SOURCES = \
- rabbit-prover.scm
+SOURCES = \
+ vikalpa.scm \
+ vikalpa/prelude.scm \
+ vikalpa/the-little-prover.scm
-TESTS =
+
+TESTS = \
+ tests/test-vikalpa.scm
TEST_EXTENSIONS = .scm