summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMasaya Tojo <masaya@tojo.tokyo>2021-09-16 12:31:44 +0900
committerMasaya Tojo <masaya@tojo.tokyo>2021-09-16 12:36:18 +0900
commit0988b883057839e1f1f6fd2c73a8ec244f4efc6c (patch)
treee74b967ce7748cbde1b139c6039fc6231b7e1309 /Makefile.am
parent33578c735d9ceddc6fca719398e290c3b2ef48fe (diff)
Generate `ChangeLog` when `make dist` is executed.v0.3.0
* Makefile.am: Add gen-ChengeLog. * build-aux/gitlog-to-changelog: New file. * ChangeLog: Replace to template.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 44052ed..9c0981a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,3 +66,10 @@ EXTRA_DIST += \
build-aux/test-driver.scm \
guix.scm \
$(TESTS)
+
+dist-hook: gen-ChangeLog
+
+gen-ChangeLog:
+ "$(top_srcdir)/build-aux/gitlog-to-changelog" > "$(distdir)/ChangeLog"
+
+.PHONY: gen-ChangeLog