summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 44052ed..9c0981a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,3 +66,10 @@ EXTRA_DIST += \
build-aux/test-driver.scm \
guix.scm \
$(TESTS)
+
+dist-hook: gen-ChangeLog
+
+gen-ChangeLog:
+ "$(top_srcdir)/build-aux/gitlog-to-changelog" > "$(distdir)/ChangeLog"
+
+.PHONY: gen-ChangeLog